How To Configure OSPF MD5 Authentitication

In this tutorial we are going to learn how to configure OSPF MD5 Authentication in cisco packet tracer.

OSPF MD5 Authentication is very semilar to the cler text authentication

Note :- While configuring the OSPF MD 5 authentication you must keep these 2 things in mind which are given blow

  • You need to configure the md5 value on an interface by using IP OSPF message-digest-key 1 md5 value interface command
  • You need to configure the interface to use MD5 authentication by using the IP OSPF authentication message-digest interface command

Screenshot (58)

Firstly assign the ip address to the router and pc and

configuration on R1:

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip add 1.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int f0/1

Router(config-if)#ip add 2.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

Router(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

configuration on R2:

Router>

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip add 2.0.0.2 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

exit

Router(config)#int f0/1

Router(config-if)#ip add 3.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

exit

After assining the ip address to the routers and pc’s now we are doing ospf routing here.

Routing configuration on R1:

Router(config)#

Router(config)#router ospf 1

Router(config-router)#network 1.0.0.0 0.255.255.255 area 0

Router(config-router)#network 2.0.0.0 0.255.255.255 area 0

Router(config-router)#

Routing configuration on R2:

Router(config)#

Router(config)#

Router(config)#router ospf 1

Router(config-router)#network 2.0.0.0 0.255.255.255 area 0

Router(config-router)#network 3.0.0.0 0.255.255.255 area 0

Router(config-router)#

After assining the ip address and routing now we have to configure OSPF MD5 Authentication

OSPF MD5 Authentication on R1:

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/1

Router(config-if)#ip ospf message-digest-key 1 md5 ccna123

Router(config-if)#ip ospf authentication message-digest

Router(config-if)#exit

OSPF MD5 Authentication on R2:

Router(config)#

Router(config)#int f0/0

Router(config-if)#ip ospf message-digest-key 1 md5 ccna123

Router(config-if)#ip ospf authentication message-digest

Router(config-if)#exit

Now how to check our OSPF MD5 Authentication is done or not

How To Check On R1

Router#show ip ospf int f0/1

How To Check On R2

Router#show ip ospf int f0/0

This is all how to configure OSPF MD5 Authentication with assining the ip addresss and routing

One thought on “How To Configure OSPF MD5 Authentitication

  1. Pingback: How To Configure OSPF Clear Text Authentication – CCNA Windows Ethical Hacking Linux Virtualization

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s