How To Configure Rip Clear Text Authentication

In this tutorial we are going to learn how to configure Rip Clear Text Authenticatiom

If you are in networking field you must know how to configure rip clear text authentication if you don’t know how to configure this rip clear text authentication so then just follow these simple things and steps.

Here you can see the diagram how i designed RIP Clear Text Authentication

Screenshot (60)

Here firstly we have to assign the iP address to both the routers and pc’s

IP Address configuration on R1:

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip add 1.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int f0/1

Router(config-if)#ip add 2.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

Router(config)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

IP Address configuration on R2:

Router>

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip add 2.0.0.2 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

exit

Router(config)#int f0/1

Router(config-if)#ip add 3.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

exit

After assining the ip address to the routers and pc’s now we are doing RIP routing here.

RIP Routing Configuration on R1:

Router(config)#

Router(config)#router rip

Router(config)#version 1

Router(config-router)#network 1.0.0.0

Router(config-router)#network 2.0.0.0

Router(config-router)#exit

Router(config)#

RIP Routing Configuration on R2:

Router(config)#

Router(config)#router rip

Router(config)#version 1

Router(config-router)#network 2.0.0.0

Router(config-router)#network 3.0.0.0

Router(config-router)#exit

Router(config)#

After assining the IP address and routing now we have to configure RIP Clear text Authentication

RIP Clear Text Authentication on R1:

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#key chain private

Router(config-keychain)#key 1

Router(config-keychain)#key-string 234

Router(config-keychain)#exit

Router(config)#

Router(config)#int f0/0

Router(config-if)#ip rip authentication key-chain private

Router(config-if)#exit

RIP Clear Text Authentication on R2:

Router(config)#

Router(config)#key chain private

Router(config-keychain)#key 1

Router(config-keychain)#key-string 234

Router(config-keychain)#exit

Router(config)#

Router(config)#int f0/0

Router(config-if)#ip rip authentication key-chain private

Router(config-if)#exit

Now how to check our RIP clear text Authentication is done or not

Clear Text Authentication Is Successfully Done Or Not By Using This Command You Can See the connand are given blow.

How To Check On R1:

Router#show ip rip database

How To Check On R2:

Router#show ip rip database

This is all how to configure RIP Clear Text Authentication with assining the IP addresss and RIP routing

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s