How To Configure EIGRP Authentication

In this tutorial we are going to learn how to configure EIGRP Authentication.

It is very easy to configure EIGRP Authentication. and if you are in networking field you must know how to configure clear text and MD5 authentication.

If you don’t know how to configure EIGRP Authentication so don’t worry just follow these simple steps and commands then you can easily understand how to configure EIGRP Authentication.

Here is the diagram of EIGRP Authentication you can see it

Screenshot (61)

Now Firstly we have to assign the IP address to both the routers and pc’s

IP Configuration On Router 1:

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip add 1.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int f0/1

Router(config-if)#ip add 2.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

Router(config)#

IP Configuration On Router 2:

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip add 2.0.0.2 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit

Router(config)#int f0/1

Router(config-if)#ip add 3.0.0.1 255.0.0.0

Router(config-if)#no shut

Router(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit

Router(config)#

After Assining the IP Address To both the routers and Pc’s Now we are doing EIGRP Routing to both the routers

EIGRP Routing Configuration On R1:

Router(config)#

Router(config)#router eigrp 1

Router(config-router)#network 1.0.0.0

Router(config-router)#network 2.0.0.0

Router(config-router)#

EIGRP Routing Configuration On R2:

Router(config-if)#exit

Router(config)#router eigrp 1

Router(config-router)#network 2.0.0.0

Router(config-router)#network 3.0.0.0

Router(config-router)#

After EIGRP Routing now we have to configure EIGRP Authentication

EIGRP Authentication On R1:

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/1

Router(config-if)#ip authentication mode eigrp 1 md5

Router(config-if)#ip authentication key-chain

Router(config-if)#ip authentication key-chain eigrp 1 ccnpkey

Router(config-if)#

EIGRP Authentication on R2:

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int f0/0

Router(config-if)#ip authentication mode eigrp 1 md5

Router(config-if)#ip authentication key-chain

Router(config-if)#ip authentication key-chain eigrp 1 ccnpkey

Router(config-if)#

Now this is all how to configure EIGRP Authentication in cisco packet tracer

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s