Advertisements
Skip to content

How to configure VPN on cisco router

Our Score
Click to rate this post!
[Total: 0 Average: 0]

In this tutorial we are going to learn how to configure Vpn on cisco router using cisco packet tracer.

It is very easy to configure vpn on cisco router just follow these simple steps

Here First you can see the diagram to understand clearly what actually we have to do for configure vpn on cisco router.

Screenshot (7)

Step-1 Here i have taken 3 routers and 2 pc’s and then i have connected them to each other

Step-2 Now we have to configure the ip address to all the routers and pc’s

Configuration on Router 1

Router>enable
Router#config t
Router(config)#int f0/0
Router(config-if)#ip add 192.168.1.1 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#
Router(config)#int f0/1
Router(config-if)#ip add 1.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config)#exit
Router#

Configuration On Router 2

Router>en
Router#config t
Router(config)#int f0/0
Router(config-if)#ip add 1.0.0.3 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int f0/1
Router(config-if)#ip add 2.0.0.1 255.0.0.0
Router(config)#exit
Router(config)#

Configuration On Router 3

Router>
Router>en
Router#config t
Router(config)#int f0/0
Router(config-if)#ip add 2.0.0.2 255.0.0.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int f0/1
Router(config-if)#ip add 192.168.2.1 255.0.0.0
Router(config-if)#no shut
Router(config)#exit
Router(config)#

Now Our Assining of the ip address to the router is complete now we have to do the routing to all the routers

Step-3 Here i am doing default routing to all the routers

Default Routing Configuration On Router 1

Router#config t
Router(config)#
Router(config)#ip route 0.0.0.0 0.0.0.0 1.0.0.1
Router(config)#exit
Router#

Default Routing Configuration On Router 3

Router#config t
Router(config)#
Router(config)#ip route 0.0.0.0 0.0.0.0 2.0.0.1
Router(config)#exit
Router#

Step-4 After Configuring default routing to the router now we have to check that routing which we have done before is working or not by pinging the router with each other so here i am going to check that

r1#ping 2.0.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 26/28/33 ms

Step-5 Now go to router3 and test that network is working or not by pinging

r3#ping 1.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 25/28/32 ms

Step-6 Now create VPN tunnel between R1 and R3:

First create a VPN tunnel on router R1:

r1#config t

r1(config)#interface tunnel 10

r1(config-if)#ip address 172.16.1.1 255.255.0.0

r1(config-if)#tunnel source fa0/1

r1(config-if)#tunnel destination 2.0.0.2

r1(config-if)#no shut

Now we have to create VPN Tunnel on router R3:

r3#config t

r3(config)#interface tunnel 100

r3(config-if)#ip address 172.16.1.2 255.255.0.0

r3(config-if)#tunnel source fa0/0

r3(config-if)#tunnel destination 1.0.0.1

r3(config-if)#no shut

Step-7 Now test communication between these two routers again by pinging eah other:

r1#ping 172.16.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 30/32/36 ms

r1#
r3#ping 172.16.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 33/45/83 ms

r3#

Step-8 Now Do routing for created VPN Tunnel on Both Router R1 and R3:

r1(config)#ip route 192.168.2.0 255.255.255.0 172.16.1.2
r3(config)#ip route 192.168.1.0 255.255.255.0 172.16.1.1

Step-9 Now here i am going to test that VPN Tunnel is configured or not

r1#show interfaces Tunnel 10

Tunnel10 is up, line protocol is up (connected)

Hardware is Tunnel

Internet address is 172.16.1.1/16

MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel source 1.0.0.1 (FastEthernet0/1), destination 2.0.0.2

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transport MTU 1476 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 32 bits/sec, 0 packets/sec

5 minute output rate 32 bits/sec, 0 packets/sec

52 packets input, 3508 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 input packets with dribble condition detected

52 packets output, 3424 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

Now going to Router R3 and test VPN Tunnel Creation:

r3#show interface Tunnel 100

Tunnel100 is up, line protocol is up (connected)

Hardware is Tunnel

Internet address is 172.16.1.2/16

MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel source 2.0.0.2 (FastEthernet0/0), destination 1.0.0.1

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transport MTU 1476 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 1

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 32 bits/sec, 0 packets/sec

5 minute output rate 32 bits/sec, 0 packets/sec

52 packets input, 3424 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 input packets with dribble condition detected

53 packets output, 3536 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

Step-10 Now how we can trace vpn tunnel path

PC>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::2E0:8FFF:FE0B:AEB2

IP Address......................: 192.168.2.2

Subnet Mask.....................: 255.255.255.0

Default Gateway.................: 192.168.2.1

PC>ping 192.168.1.2

Pinging 192.168.1.2 with 32 bytes of data:

Reply from 192.168.1.2: bytes=32 time=61ms TTL=126

Reply from 192.168.1.2: bytes=32 time=55ms TTL=126

Reply from 192.168.1.2: bytes=32 time=55ms TTL=126

Reply from 192.168.1.2: bytes=32 time=57ms TTL=126

Ping statistics for 192.168.1.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 55ms, Maximum = 61ms, Average = 57ms

PC>tracert 192.168.1.2

Tracing route to 192.168.1.2 over a maximum of 30 hops:

1 3 ms 0 ms 18 ms 192.168.2.1

2 35 ms 30 ms 30 ms 172.16.1.1

3 65 ms 59 ms 60 ms 192.168.1.2

Trace complete.

PC>
This is all how to configure vpn on cisco router using cisco packet tracer.

If you learn something about from this post then make sure you
like this post and follow my website to learn some intresting topic about the kali linux,
website desining,windows,virtualization,cyber security and much more intresting topics.

If you want to learn about cyber security in detail and if you want practical training of cyber security
with detail notes so check this product it will give you the best knowledge with practical training.

Cyber Security Training Notes

Advertisements

Leave a Reply

Discount Offer

Now Get 50% Discount

On Cyber Security Training                                                       Notes  

Click here  To Purchase

%d bloggers like this: